FBA User Management not Working

Nov 4, 2007 at 6:09 PM
Hi There,

We are getting an error (Unknow error to be exact without any explanation) when trying to access the FBA User Management option. Does anyone have an idea how to check the error of how to solve this problem?

The page is:
/_layouts/FBA/Management/UsersDisp.aspx

Thanx!

Danny Burlage
Nov 15, 2007 at 3:07 PM
Hi Danny,

Were you able to get this issue resolved? I'm experiencing the same issue!

Thanks,

Tad
Nov 15, 2007 at 3:14 PM
Edited Nov 15, 2007 at 3:15 PM
Only "site admin" can view this page.
But I want to let the group owner see this page. Also I want to let group owner see his group members in this page.
How can I?
Thank you.
Nov 21, 2007 at 3:43 PM
I'm getting the same issue with /_layouts/FBA/Management/UsersDisp.aspx giving an unknown error. Nothing in the sharepoint logs or event log.
I can create my roles, and from the "manage roles" screen actually create FBA users, I just can't manage them. Any idea's where to start looking?
Cheers,
Ross
Nov 27, 2007 at 6:21 AM
Send email to werner@umayr.net an I will send you the corrected aspx pages to enable these features...
Nov 27, 2007 at 2:39 PM
When creating a new user, I get the error "The password-answer supplied is invalid." (on the UserNew.aspx) which appears to be a web.config setting. I am trying different settings in the web.config but if anyone knows exactly where I should fix it, please reply. Thanks!
Nov 27, 2007 at 5:48 PM
My problem was twofold: 1) the web.config did not have the entries for the connection string and the providers (above and below the system.web, respectively). I mistakenly added the provider to the existing provider list which was in the wrong area (see below), and 2) the real problem was the requiresQuestionAndAnswer="false" key was set to true (or non-existant).

...directly above <system.web>...
<connectionStrings>
<remove name="LocalSqlServer" />
<add name="LocalSqlServer" connectionString="Server=TF-SP-MOSS;Database=aspnetdb;uid=TRG;pwd=P@ssw0rd;" providerName="System.Data.SqlClient" />
</connectionStrings>
...directly below <system.web>...
<membership defaultProvider="AspNetSqlMembershipProvider">
<providers>
<remove name="AspNetSqlMembershipProvider" />
<add connectionStringName="LocalSqlServer" passwordAttemptWindow="10" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" applicationName="/" requiresUniqueEmail="false" passwordFormat="Hashed" description="Stores and retrieves membership data from the Microsoft SQL Server database" name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.3600.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
</providers>
</membership>

I mistakenly assumed the FBA settings were in place for user management to work, where in fact only the connection string was required to authenticate. I would like to remark that the CodePlex user management is a true enhancement to SharePoint and very well written!
Nov 29, 2007 at 1:07 PM
Has anyone resolved the users management issue? I need to set the mails of users to configure alerts to them.

Regards
Sacksan
Dec 14, 2007 at 2:38 PM
I have the same error: "The password-answer supplied is invalid."
I am new to .NET and followed what virtualspy posted above.
It must have something to do with requiresQuestionAndAnswer but I have no results so far.
Please help!

Thank you.
Feb 11, 2008 at 10:20 PM
I'm facing the same problem.
When i go to FBA User Management the browser goes to

http://portal.deepeye.pt/_layouts/FBA/Management/UsersDisp.aspx

and should go to

http://portal.deepeye.pt/sites/PRTBBD/_layouts/FBA/Management/UsersDisp.aspx


Please help!

Thank you.

Mar 26, 2008 at 9:51 AM
Edited Mar 27, 2008 at 3:11 AM
I'm facing it too

I got the trace and exception back says :

Microsoft.SharePoint.SPListCollection.GetListByName(String strListName, Boolean bThrowException)
at Microsoft.SharePoint.SPListCollection.get_Item(String strListName)
at CKS.FormsBasedAuthentication.FBAUsersView.ExecuteSelect(DataSourceSelectArguments selectArgs)
at System.Web.UI.DataSourceView.Select(DataSourceSelectArguments arguments, DataSourceViewSelectCallback callback)
at System.Web.UI.WebControls.DataBoundControl.PerformSelect()
at System.Web.UI.WebControls.BaseDataBoundControl.DataBind()
.......

Can you see the problems is and tell me what to do?
Thanks for help

-----------------------
thanks you guys, problem is soved
Jun 24, 2008 at 3:52 PM
I compiled a fixed version for a german sharepoint installation (other Userlist-name). You can download updated dll here.
Works perfekt for me, but no warranty.
Jun 24, 2008 at 3:52 PM
Edited Jun 26, 2008 at 11:57 AM
Note:
The above published File is UNOFFICIAL. I am not a member of this Project and there can be no claims for help or - in worst case - refunds if something happens.

However I used the file at a customer and they are very happy with it because it is working :) 

Simply substitute the dll on the SharePoint Server(s) in the GAC (C:\Windows\assembly). You will have to drag and drop it (copy/paste will not work). Run an iisreset to apply the change.
The original Solution must be installed first. The above linked dll file alone will do nothing.

The compiled dll comes from the Source Package Version 11382

_______________________________________
Follow the red gecko...
May 19, 2009 at 6:38 PM

Do you still have these changes available?

 

-Thumphries

May 20, 2009 at 4:58 AM
Edited May 20, 2009 at 5:02 AM

Hi,

yes you can download the compiled dll for a german SharePoint here (please recognize my note about this UNOFFICIAL file in my post from Jun 24 2008 at 5:52 PM).

I only changed Line 36 in file FBAUsersView.cs to:

SPList  list = web.Lists["Benutzerinformationsliste"];

Greetz

May 26, 2009 at 8:04 PM

I have configured cks as per VirtualSpy's reply, I am still getting the error as described in the original post

Unknow error to be exact without any explanation) when trying to access the FBA User Management option or the FBA Role Management option.  Can someone tell me what causes that?

Developer
May 26, 2009 at 10:45 PM

You're seeing a standard SharePoint error page.  You can get more detailed error information if you enable the call stack, as per Angus Logan's blog:

http://blogs.msdn.com/angus_logan/archive/2006/12/16/how-to-enable-debugging-in-wss-3-0.aspx

Basically you edit your web.config like (changes are in red below:

<SafeMode MaxControls="200" CallStack="true" ...>

<customErrors mode="Off" />

<compilation batch="true" debug="true">

This should give you an error message that will help diagnose the issue.

Regards,

Mike Sharp

May 27, 2009 at 8:48 PM

Mike

Thanks very much for your assistance.  The application pool account did not have permission to execute code on the Authentication database.  All is well now.

Best,

Vinit

From: rdcpro [mailto:notifications@codeplex.com]
Sent: Tuesday, May 26, 2009 6:45 PM
To: vinit.johri@deccantech.com
Subject: [SPAM] Re: FBA User Management not Working [CKS:17362]

From: rdcpro

You're seeing a standard SharePoint error page. You can get more detailed error information if you enable the call stack, as per Angus Logan's blog:

http://blogs.msdn.com/angus_logan/archive/2006/12/16/how-to-enable-debugging-in-wss-3-0.aspx

Basically you edit your web.config like (changes are in red below:

<SafeMode MaxControls="200" CallStack="true" ...>

<customErrors mode="Off" />

<compilation batch="true" debug="true">

This should give you an error message that will help diagnose the issue.

Regards,

Mike Sharp

Read the full discussion online.

To add a post to this discussion, reply to this email (CKS@discussions.codeplex.com)

To start a new discussion for this project, email CKS@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe or change your settings on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com