This project is read-only.

CKS FBA - Authentication Question/Issue

Topics: General/Misc., Internet/Extranet Edition, User Group Edition
May 6, 2010 at 8:14 PM

Hello.  We recently implemented the CKS FBA modules on a SharePoint 2007 site.  Pretty much everything is working great, but I ran into a problem I'm trying to figure out and was hoping you folks could offer some suggestions.

Our site uses the CKS FBA as the default authentication method via the primary site.  We have the site extended and use the server address as the URL internally to access the site on the intranet and use our Active Directory accounts to login.  This all works fine.

We were trying to write a custom search web part and I started out with some code from Microsoft's technet site (  Literally, I copied and pasted the code from their web site into a new C#.Net webpart, compiled, and deployed.  Everything worked fine.  However, I was logged in using an Active Directory user ID.

When I logged in using one of my FBA IDs (and one with Admin rights) to the site, the web part shows up just fine.  Performing the search, however, returns no results.  The results grid returns just fine because the header row is present.  There are no exceptions thrown that I can see.  But there are no results in the grid.  Seems to me like potentially a permissions issue, but using the out of the box search and advanced search for the same site work fine and return plenty of results.

I'm really not sure why it is any different between our AD user IDs and the FBA user IDs.  Can anyone offer any suggestions of what to check?

My background... I'm fairly new to SharePoint.  I've been working in it for a little over a year.  I wouldn't consider myself anywhere near an expert, far from it.  But I'm also not completely a novice either.

Thanks everyone!