Latest Builds

Topics: Internet/Extranet Edition
Jan 31, 2008 at 4:01 PM
Hello all,

How can I deploy the latest version (posted under "Source Code") ? Where can I get the corresponding Binaries?


(I do not have access to Visual Studio so I can't build the solution myself. )

TIA
Yonz
Feb 6, 2008 at 2:30 AM
Yonz,

First, get a free copy of Visual Studio 2005 Express C# - http://www.microsoft.com/express/2005/download/default.aspx# Once you install it on your sharepoint server, open the source code and right click FormsBasedAuthentication (FBA) and click properties. In the build window make sure you set the warning level to 0 and check Allow unsafe code (I had to do this or it wouldnt build). Right click FBA and click build. I did this a couple times and it worked great. Use the source code from http://www.codeplex.com/CKS/SourceControl/ListDownloadableCommits.aspx as it works very well and is updated from the Oct 2007 code. Once you build it successfully go to the code folder and copy the path to the folder and then open a command prompt and cd to that path. Then type deploy http://www.yourwebsite.com and watch the magic happen.

yonz wrote:
Hello all,

How can I deploy the latest version (posted under "Source Code") ? Where can I get the corresponding Binaries?


(I do not have access to Visual Studio so I can't build the solution myself. )

TIA
Yonz

Mar 26, 2008 at 3:40 PM
Hello,

I was wondering if you can point me in the right direction. I'm using visual studio 2005 and I right clicked on the Solution 'CKS.InternetExtranetEdition' and ran build. The build ran fine (i think, at least no errors).
The question for me is Now what. I know that sounds stupid, but I'm not big into .net and vs2005 yet (I emphasize yet).
When I looked in the folder bin I found three things, a FBAManagement.wsp, FBAManagement.cab and a Debug folder.
I simply thought that the FBAManagement.wsp could just deploy like the downloadable binaries on this site, but I'm getting a bunch of errors like "Failed to find the XML file at location '12\Template\Features\FormsBasicAuth\fea
ture.xml'"

It looks like I need to do something with the files in the CAB that was created.

Anyideas?

Thanks so much

Jim