MySite webpart height

Topics: User Group Edition
Feb 6, 2008 at 12:30 PM
Ok,

I succesfully installed the MySiteCreate solutions. I can add, edit and delete webparts via the XML configuration file.
The only problem i faced till now is when i enter a new property for 'height'. It seems like this property is completely ignored.

Here is a snippet from my XML file:
-------------------------------------------------------------------------------------------------------------------
<WebPartAction>
<assemblyName></assemblyName>
<className></className>
<zoneID></zoneID>
<zoneIndex></zoneIndex>
<typeName>Microsoft.SharePoint.Portal.WebControls.OWACalendarPart</typeName>
<Action>SetProperties</Action>
<Properties>
<Property Key="OWAServerAddressRoot" Value="http://exh01/exchange"/>
<Property Key="MailboxName" Value="administrator"/>
<Property Key="Height" Value="350px"/>
<Property Key="Width" Value="100"/>
</Properties>
</WebPartAction>
------------------------------------------------------------------------------------------------------------------
The properties and the values for OWAServerAddressRoot and MailboxName work perfectly, only the width and the height are ignored.

Does anyone have an idea how this problem can be solved. I think this project has great potential.

Thanks in advance.

Paul Willen
Oct 28, 2009 at 11:30 AM

Me too having the same issue and it accepts only string values!

I found this, when i used:

<Property Key="Hidden" Value="True"/>

I am getting:

Error setting property value Hidden to True: Object of type 'System.String' cannot be converted to type 'System.Boolean'.

Any idea how to set hidden to true? and other properties which is not string?

Thanks,

Pravin