Large amount of "TrackBack" spam on EBE 2.0

Topics: Enhanced Blog Edition
Mar 18, 2008 at 9:26 AM
Hi

I have a EBE 2.0 blog at http://www.pings.dk/blog. Is receive a very lage amount of Trackback spam.

How do you avoid this? Alternativly, how do I disable trackback completely? It is really annoying!
Developer
Mar 18, 2008 at 4:09 PM
You should be able to disable it in the CKS:EBE settings page.

--Vince
Mar 18, 2008 at 9:54 PM
Yeahh so I thought too. But the settings has no effect. The Linkbacks is still popping in with 10-50 per hour.
Developer
Mar 19, 2008 at 8:34 AM
Linkbacks are declared in the <head> section and so by removing the entries no-one will be able to find your trackback handler.

Modify Head.xsl for your theme, removing the following lines...

	<link rel="trackback" type="application/x-www-form-urlencoded" href="{$RelativeUrl}/_layouts/cks/ebe/Trackback.aspx?ID={ID}" />
	
	<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
             xmlns:dc="http://purl.org/dc/elements/1.1/"
             xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
    <rdf:Description
        rdf:about="{$PostFullUrl}"
        dc:identifier="{$PostFullUrl}"
        dc:title="{Title}"
        trackback:ping="{$RelativeUrl}/_layouts/cks/ebe/Trackback.aspx?ID={ID}" />
    </rdf:RDF>	

This should stop the spam.

--Vince
Mar 19, 2008 at 2:42 PM
Thanks Vince. Just delted that. Now I'll just hope they have'nt cached the damn URL :)
Sep 5, 2008 at 3:39 PM
This sounds like a work around, but I would like to try it out if our admins can find some time. Any chance Akismet can deal with this so we wouldn't have to disable trackbacks?