CKS:EBE - Integrated Authentication Question

Topics: Enhanced Blog Edition
Apr 10, 2008 at 4:45 PM
Hi, I installed the CKS:EBE yesterday over the top of our existing WSS 3.0 site, and I'm having some issues with integrated authentication. The blog that I've set up is meant to be used by a handful of people (all in an Active Directory group) and viewed/commented on by a larger group of people (another AD group.) If I disable the EBE everything works fine, but when I enable the EBE only my user account can create new posts. Other members of the admin AD group don't have any of the options. We all have a "Sign In" link at the top of the page that doesn't appear to do anything. Users are authenticated with their domain logon, so we'd like to eliminate any second sign-in.

I saw in another post that disabling anonymous access was suggested to fix a similar problem, but I didn't see that option in there. Any suggestions would be welcomed, and thanks for putting together an awesome package :)

-Mike
Developer
Apr 22, 2008 at 9:23 PM
Mike,

Firstly sorry for the late response!

Chances are they can still create posts (EBE doesn't mess with SharePoint permissions), but the option isn't shown in the Admin? I think you have to be Web Admin for the Admin stuff to appear. You can change this in your theme.

Some of the themes don't remove the sign-in link & I doubt you would see any difference if you are not Web Admin. Have a look at the Admin.xsl and the theme .master page...its definitly possible, probably a bit of an oversight on our part...sorry.

--Vince
Apr 29, 2008 at 10:01 PM
You were right about the permissions - they had the ability to post, but the option wasn't visible. I was able to add a link to "Create Posts" to remedy that.

Regarding the sign-in button, I found the theme.master page (C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE\FEATURES\CKS EBE Themes\Themes\Intensive\theme.master) and the line of code where the sign-in is but editing that does not change the live site. Where should I be making that change to have it affect the blog?

Thanks,

Mike



TheKid wrote:
Mike,

Firstly sorry for the late response!

Chances are they can still create posts (EBE doesn't mess with SharePoint permissions), but the option isn't shown in the Admin? I think you have to be Web Admin for the Admin stuff to appear. You can change this in your theme.

Some of the themes don't remove the sign-in link & I doubt you would see any difference if you are not Web Admin. Have a look at the Admin.xsl and the theme .master page...its definitly possible, probably a bit of an oversight on our part...sorry.

--Vince

Developer
Apr 29, 2008 at 11:20 PM
Mike,

Some of the themes don't include this. In the AdminLinks.xsl you need the following...

	<xsl:if test="$IsBlogOwner = 'True'">
		<xsl:apply-templates select="AdminLinks"/>
	</xsl:if>
 
	<xsl:if test="$IsBlogOwner != 'True'">
		<a>
			<xsl:attribute name="href">
				<xsl:value-of select="$RelativeUrl"/>/_layouts/authenticate.aspx?ReturnUrl=<xsl:value-of select="$RelativeUrl"/>
			</xsl:attribute>
			Sign In
		</a><br/>
	</xsl:if>

This is taken from my blog. Your SignIn link is probably hard coded, so you need to move it (to where the AdminLinks appear) or create a new xsl file just for the 'Sign In' link, copy the <EBE:..../> where the admin links appear and specify your new XSL which just shows the Sign In link.

HTH, Vince