CKS:EWE Installation

Topics: Enhanced Wiki Edition
May 27, 2008 at 4:33 PM

I've tried many times now to install CKS:EWE Beta 2 and am having no luck.  The directions in the Beta 2 PDF do not work.

Could anybody please give me a step-by-step?

It doesn't seem like it should be very difficult.  Running deploy.cmd from the release download is nothing but failures to find feature.xml.  I tried copying the source tree to the \12 directory and this solves the missing feature.xml issue.  I can then find the CKS wiki option in sharepoint, but trying to create a page gives an error.

Thank you,

May 30, 2008 at 7:08 AM
Hi Spencer,
You should be able to get it to work without copying the source tree to the 12 hive. I base this assumption on that I managed it. :-)

The error message about the missing feature.xml, when does that show? Is it when you are running deploy.cmd? In that case, the deploy.cmd starts off with uninstalling the EWE, and when uninstalling a feature that does not exists in SharePoint yet, that message will display. But as the feature does not exists, this message can safely be ignored. Once deploy.cmd has executed once and installed the EWE, you should be able to re-execute deploy.cmd without the error message.

Jul 31, 2008 at 7:18 PM
Sorry if this question seems really basic, but I can't find the "release download", a \12 folder, or feature.xml. I'm using the basic Windows search. Do you know where this folder should be? Do I have to load it through Sharepoint, or can I browse to it in Windows Explorer?

Many thanks,
Aug 6, 2008 at 4:42 PM
Edited Aug 6, 2008 at 5:07 PM
A clarification: I'm running Microsoft Sharepoint Services 3.0, -not- Sharepoint Server. I found the \12 folder at C:\Program Files\Common Files\microsoft shared\Web Server Extensions\12\, but I still get an error about not finding a feature.xml file. I ran the deploy.cmd in the same folder with my sharepoint web site as the parameter (deploy.cmd http://oursitename) but I'm getting the error "Failed to find the xml file at location 12\Template\Features\CKSEWEContent\feature.xml" I can't find a Template folder in the 12 folder or anywhere else. Does this help? Is the community kit compatible with Microsoft Sharepoint Services? Any advice would be greatly appreciated.

Thanks again,

Edit: I found this discussion after a google search:
Aug 11, 2008 at 5:27 PM

The initial deployment will throw those errors, because deploy.cmd first tries to deactivate and retract the solution, which hasn't been installed yet.  Remove any stuff you may have copied to the 12 hive, comment out the lines as I show below (note the REM ), and save the file as "InitialDeploy.cmd".  Then run the cmd file.

@echo Deploying CKSEWE solution

@set PATH=C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN;%PATH%

@if "%1"=="" (goto invalidParameters)

REM stsadm -o deactivatefeature -name CKSEWEContent -url %1 -force
REM stsadm -o deactivatefeature -name CKSEWEFields -url %1 -force
REM stsadm -o deactivatefeature -name CKSEWELibrary -url %1 -force
REM stsadm -o deactivatefeature -name CKSWikiDiscussionsList -url %1 -force
REM stsadm -o uninstallfeature -name CKSEWEContent -force
REM stsadm -o uninstallfeature -name CKSEWEFields -force
REM stsadm -o uninstallfeature -name CKSEWELibrary -force
REM stsadm -o uninstallfeature -name CKSWikiDiscussionsList -force
REM stsadm -o retractsolution -name CKSEWE.wsp -immediate -url %1
REM stsadm -o execadmsvcjobs
REM stsadm -o deletesolution -name CKSEWE.wsp -override
stsadm -o addsolution -filename Package\CKSEWE.wsp
stsadm -o deploysolution -name CKSEWE.wsp -immediate -allowgacdeployment -force -url %1
stsadm -o execadmsvcjobs
stsadm -o installfeature -name CKSEWEContent -force
stsadm -o installfeature -name CKSEWEFields -force
stsadm -o installfeature -name CKSEWELibrary -force
stsadm -o installfeature -name CKSWikiDiscussionsList -force
stsadm -o activatefeature -name CKSEWEContent -url %1
stsadm -o activatefeature -name CKSEWEFields -url %1
stsadm -o activatefeature -name CKSEWELibrary -url %1
stsadm -o activatefeature -name CKSWikiDiscussionsList -url %1

@goto endOfBatch

 @echo Please call with the correct parameters.
 @echo The correct syntax of this command is:
 @echo Deploy [siteurl] 



If you want the latest version, you'll need to get it from the source and create a new solution package with Package.cmd.  Be sure to build the solution first!

Mike Sharp


Aug 11, 2008 at 5:30 PM

By the way, there should be a TEMPLATE folder in the 12 hive; if not, you may want to re-install WSS 3.0.

The folder is at:

C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\TEMPLATE

and it contains a lot of the stuff that WSS needs to work.

Mike Sharp

Aug 12, 2008 at 2:16 PM
Thanks you very much for the help!