FBA: Login webpart appears blank

Topics: Internet/Extranet Edition
Jun 25, 2008 at 2:26 PM
Hello,
    I have installed the FBAManagement package in a test MOSS environment, with Windows auth working on one application, and forms-based auth working on an extended application. The FBA user management pages appear in the Site settings page and are working.

   I have set anonymous acces for the FBA site, and this is working. I added the Login webpart to the default page, but it only appears as a blank area. This is the same viewing the page as anonymous vs. logged in as the site administrator. I tried changing many settings on the webpart, including a fixed size, but nothing caused the username and password fields to show up. If I check 'Visible When Logged In?' in the advanced section of the webpart config, then the fields are visible, but only after logging in through the standard MOSS login page.

   The other user management webparts are visible when added to a page - I have not tried to actually use them yet.

    Any ideas?

Thanks in advance,

JDC
Jul 15, 2008 at 8:26 PM
I'm encountering the exact same issues with the login web part.  Maybe Paul Ballard could chime in with the proper way to set up our sites and these web parts.  The installation went super smooth, but I'm not exactly sure how to configure the rest of the web parts to get the overall system up and running.



Dan
Jul 16, 2008 at 7:49 PM

It looks like the blank web part is working as designed.  It will only show up with a username and password once you've got anonymous access working properly.  I read the following blog posts (and those it links to) to get this working:  

http://weblogs.asp.net/bsimser/archive/2006/09/25/Enabling-anonymous-access-in-SharePoint-2007.aspx
http://www.sharepointblogs.com/mirror/archive/2007/10/19/install-and-configure-the-community-kit-for-sharepoint-internet-extranet-edition.aspx


For some reason I was not able to set the anonymous properties at first by adding the _layouts/setanon.aspx to the end of the site.  I had to go back into the Central Administrator, re-apply the anonymous setting for my site's zone (I used Extranet), then restart IIS.  When I went back to the setanon page the anonyous options were no longer grayed out.  Once I was able to set up the anonymous access for the site I was able to see the logon fields.  I then went in and started to turn off anoymous access for all the web parts.  Rich did it little better in his blog post by using subsites but we need to have everything on one page.

Sep 18, 2008 at 8:44 AM
Edited Sep 18, 2008 at 8:52 AM
Im glad i finally find a resource like this for MOSS.