Delete WebParts

Topics: Corporate Intranet Edition, Internet/Extranet Edition
Jun 30, 2008 at 2:10 AM

Nobody seems to be struggling with this whole adding and removing webparts, but me. So I am going to humbly ask what I am doing wrong. I thought I would start small and just delete the Calendar WebPart and I can't even do that. Ultimately I would like to remove all webparts and just add the “PageViewer” webpart with a custom configuration. Looking at my XML file can someone tell me what I am doing wrong?

 

<WebParts>
 <WebPartAction>
  <assemblyName>Microsoft.SharePoint.Portal, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c</assemblyName>
  <className>Microsoft.SharePoint.Portal.WebControls.ThisWeekInPicturesWebPart</className>
  <zoneID></zoneID>
  <zoneIndex></zoneIndex>
  <typeName></typeName>
  <Action>Delete</Action>
  
 </WebPartAction>
 <WebPartAction>
  <assemblyName></assemblyName>
  <className></className>
  <zoneID></zoneID>
  <zoneIndex></zoneIndex>
  <typeName>Microsoft.SharePoint.Portal.WebControls.PersonalWelcomeWebPart</typeName>
  <Action>Delete</Action>
 </WebPartAction>
 <WebPartAction>
  <assemblyName></assemblyName>
  <className></className>
  <zoneID>BottomZone</zoneID>
  <zoneIndex></zoneIndex>
  <typeName>Microsoft.SharePoint.Portal.WebControls.RSSAggregatorWebPart</typeName>
  <Action>Delete</Action>
 </WebPartAction>
 <WebPartAction>
  <assemblyName></assemblyName>
  <className></className>
  <zoneID>MiddleLeftZone</zoneID>
  <zoneIndex></zoneIndex>
  <typeName>Microsoft.SharePoint.Portal.WebControls.RSSAggregatorWebPart</typeName>
  <Action>Delete</Action>
 </WebPartAction>

 <WebPartAction>
  <assemblyName></assemblyName>
  <className></className>
  <zoneID>MiddleRightZone</zoneID>
  <zoneIndex></zoneIndex>
  <typeName>Microsoft.SharePoint.Portal.WebControls.OWACalendarPart</typeName>
  <Action>Delete</Action>
  
 </WebPartAction>
</WebParts>