New Installation - Parse Error

Topics: Enhanced Blog Edition
Jul 8, 2008 at 8:12 PM

Installed EBE with no problems, activated the feature on my Blog Site.
I can type in to go to the /themes page, but I cannot navigate there because my homepage is not working. 
When I navigate to my Blog home page I get: 

Server Error in '/' Application.

Parser Error

Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Value cannot be null.
Parameter name: value

Source Error:

[No relevant source lines]

Source File: /TEST/Blog/themes/default/theme.master    Line: 1

 


Version Information: Microsoft .NET Framework Version:2.0.50727.832; ASP.NET Version:2.0.50727.832

 

Developer
Jul 10, 2008 at 9:39 PM

Hi,

Can you ty some of the following...

Naviagate to http://<your domain>/default.aspx?theme=intensive (or any of the other themes), just to see if it just that theme.

Run up DebugView to see if there are any err. I don't think I would expect anything, but you never know.

Check that the WebApplication feature is enabled (I'm guessing it is).

Create a subsite and activate the feature...does that work?

De-activate & re-activate, does that fix it?

--Vince

Jul 11, 2008 at 3:27 PM
None of the suggestions resolved the error.
WebApplication is enabled
I didnt get any errors w/DebugView

Any other ideas?
Developer
Jul 13, 2008 at 7:55 AM
Mellissa,

Can you open the file "/default/theme.master" in SharePoint designer? Is it un-ghosted (little blue icon next to it)?

Can you get to http://<youblog>/_layouts/settings.aspx?

From the CKS:EBE settings page can you disable the MTF?

Do you get the same error from the test blog subsite?

Can you check the FEATURES\CKS\EBE folder to ensure the themes are there?

--Vince
Jul 15, 2008 at 9:20 PM
/default/theme.master is un-ghosted and comes up with the default blue world type theme with no problems.
I can get to the settings page as well as any other list or library on the blog site except for the default.
Disablilng MTF fixes the error, but none of the themes I select on the CKS:EBE settings page appear. Just the regular default.master page we have specified.
When I attempt to Format > Master Page > Attach Master Page and then choose one of the theme.master files, the changes are not applied.
Where would I acces the \features\CKS\EBE  file from? Through Designer within the blog site? somwhere else?
Thanks,
Melissa
Developer
Jul 15, 2008 at 10:43 PM
Melissa,

The EBE feature folder is in the 12 hive (c:\program files\microsoft shared\web server extensions\12)

You would not be able to attach a master page as it is dymaically assigned at runtime based on your selected theme.

I don't think your (Theme) master page should be un-ghosted, could you try reverting it to the site definition?

As disabling the MTF works I assume the rest of the EBE is working. Can you try re-naming the themes\default folder to something else and then rename one of the other themes to 'default'?

--Vince
Jul 17, 2008 at 2:18 PM
renaming doesn't work.
Oct 8, 2008 at 10:08 PM
Has there been any resolution to this issue?  I am getting a similar one- after I have activated the CKS:EBE feature for the site, the site is not displayed and that "value cannot be null" error is returned.
  Thanks,
  -Felix
Oct 8, 2008 at 10:09 PM

I never found a resolution, to be honest I just gave up. No one could help me.

Melissa McElroy

Systems Analyst

Group O

(309)736-8323

From: FrontEndLoader [mailto:notifications@codeplex.com]
Sent: Wednesday, October 08, 2008 5:09 PM
To: Melissa McElroy
Subject: Re: New Installation - Parse Error [CKS:31106]

From: FrontEndLoader

Has there been any resolution to this issue? I am getting a similar one- after I have activated the CKS:EBE feature for the site, the site is not displayed and that "value cannot be null" error is returned.
Thanks,
-Felix

Read the full discussion online.

To add a post to this discussion, reply to this email (CKS@discussions.codeplex.com)

To start a new discussion for this project, email CKS@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Developer
Oct 13, 2008 at 9:37 PM
I believe this is a problem with the master page. WSS doesn't like ghosted master pages outside of _catalogs.

Try editing the master page in SPD and saving it.

--Vince
Nov 25, 2008 at 7:40 AM
Edited Nov 25, 2008 at 7:44 AM
Hi Melissa, Vince

I have been getting the same error.   I did a bit more digging and found a couple of extra pieces which may/may not help.

The error (at least in my case) came back to the $BlogUrl - ThemeExpressionBuilder items in the theme master page, for some reasone these weren't working.   When I removed these tags the site came up.   The other issue I found was that it only seemed to occur on a particular managed path.   In my environment I have three managed paths: <ServerName>/sites; <ServerName>/clients and <ServerName>/blogs>.   The EBE feature worked successfully with no problems on 'clients' and 'blogs' but failed no matter what I tried on the 'sites' managed path.

I will continue to investigate this and provide any further info as I find it.

Any help is appreciated.

Cheers
Pete