This project is read-only.

Object reference not set to an instance of an object. at CKS.FormsBasedAuthentication.FBAUsersView.ExecuteSelect(DataSourceSelectArguments selectArgs)

Topics: Internet/Extranet Edition
Aug 27, 2008 at 10:35 AM
Edited Sep 2, 2008 at 12:35 PM
i deploy FBAManagement to my sharepoint server.  but i dont get all 4 link in my Settings page i got thise 2 link only
  FBA Membership Request Management
  FBA User Management

first link works properly, but when i click the second link i got the following error--->

Object reference not set to an instance of an object.   at CKS.FormsBasedAuthentication.FBAUsersView.ExecuteSelect(DataSourceSelectArguments selectArgs)
   at System.Web.UI.DataSourceView.Select(DataSourceSelectArguments arguments, DataSourceViewSelectCallback callback)
   at System.Web.UI.WebControls.DataBoundControl.PerformSelect()
   at System.Web.UI.WebControls.BaseDataBoundControl.DataBind()
   at System.Web.UI.WebControls.GridView.DataBind()
   at System.Web.UI.WebControls.BaseDataBoundControl.EnsureDataBound()
   at System.Web.UI.WebControls.CompositeDataBoundControl.CreateChildControls()
   at System.Web.UI.Control.EnsureChildControls()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Control.PreRenderRecursiveInternal()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
Aug 27, 2008 at 10:13 PM
Are you using the latest source code, or the October release?  It sounds like some of the features either didn't get deployed, or were not activated, or if you built the source yourself, not everything is included in your WSP.  Is FBA already set up and working on the site?

Mike Sharp
Aug 28, 2008 at 10:00 AM
Hi Mike,
thank you for quick reply, i activated FBA in my site using but i dnt have any screen for insert, update user and role.i use asp configuration. Later i install this solution. is the previous changes causing problem? i did not make any change in  the source code. i am using the latest one.

Zobayer Rabbi
Aug 28, 2008 at 3:58 PM
There was a release in October, which is the only release for the FBA management part.  Is that what you  installed, or did you get the latest source code and compile it?

Mike Sharp
Aug 28, 2008 at 4:17 PM
Sorry I install "IEE Forms Based Authentication Solution" released on October.
i download the CKS today. today i will install it

Zobayer Rabbi
Aug 28, 2008 at 4:31 PM
Ah, good.  Check this discussion list and the issues tracker for some fixes that need to be made.  There have been posts about it over the last few weeks.

Sep 1, 2008 at 3:39 PM
Hi Mike,
i deploy the new release and i get the same error. 
Zobayer Rabbi
Sep 1, 2008 at 11:35 PM
I think there will be a new release very soon, within the next day or so.  I'm co-ordinating with Anthony Sumner on this, and we're on different continents, but you should have something soon.  If not, I'll post back here with instructions on how to download a WSP from one of my SharePoint sites.

Mike Sharp
Sep 3, 2008 at 8:41 AM
Hi Mike,
Did you submit the new release. i saw some new submition of urs in source code section. which one should i deploy?

Zobayer Rabbi
Sep 3, 2008 at 3:39 PM
We don't have a release quite yet; I'm still setting that up, but the latest version of the source code should be pretty close.  There are a few things that don't work that I know of.  For example, auto-approve still isn't working.  Anthony Sumner is working on that today, I believe.  I think we're hoping that we can get the auto-approve in it, but if you need something right away, let me know and I'll post a WSP on one of my SharePoint sites. 

But if you download the latest source, you should have something close.

Mike Sharp
Sep 3, 2008 at 4:00 PM
I install from the latest download. but its saying the same. i think there is some problem in my server. i cannot undeploy the project. i want to undeploy and delete all the things and install it newly. while i enter deletesolution, i got error now exist in the solution store? and after that while i try to install i got the same error. if you can help me about proper installation and deploy that will help me a lot

Zobayer Rabbi
Sep 3, 2008 at 5:45 PM
Something does seem messed up with your server.

What happens when you run:
UnDeploy.cmd "http://yoursite"

where "http://yoursite" is your site collection URL?
Sep 3, 2008 at 5:54 PM
Also, this seems like a permissions problem.  Worst case, you might need to back up your content databases, uninstall WSS/MOSS making sure to delete everything in the 12 hive afterward, reinstall, and restore your content databases.  This will ensure you have a clean environment.  You'll have to recreate the web applications and site collections in your farm, then re-attach the newly restored content databases.  There's instructions for this on the web.

To get this FBA Management solution working, the main thing is you need forms based authentication working on the site collection from the start.  And you need at least one user account in the FBA membership store that is also a site collection administrator.  Dan Attis has a good blog on how to set up forms auth for SharePoint:

Make sure this is working before you attempt to install the solution.  Also, if you still have problems after you try to install the solution, make sure your assembly can install to the GAC.  I've had troubles with this before, and you can get all sorts of wacky errors.  After you install the solution, and you're still having troubles, run this from the command line in the root directory of the source (where is):

gacutil /i bin\Release\CKS.FormsBasedAuthentication.dll /f

Or, if you're using a debug version of the DLL, run:

gacutil /i bin\Debug\CKS.FormsBasedAuthentication.dll /f




Sep 4, 2008 at 11:03 AM
Today while i was accessing Manage Web application features i got the following error? i re-install the MOSS. after that i got this error. i think this error have connection with the FBA error.

Object reference not set to an instance of an object.   at Microsoft.SharePoint.WebControls.FeatureActivator.get_FeatureCollection()
   at Microsoft.SharePoint.WebControls.FeatureActivator.AddFeaturesToTable(DataTable& dtblFeatureList)
   at Microsoft.SharePoint.WebControls.FeatureActivator.BuildFeatureListDataTable()
   at Microsoft.SharePoint.WebControls.FeatureActivator.get_FeatureListDataTable()
   at Microsoft.SharePoint.WebControls.FeatureActivator.OnLoad(EventArgs evtargs)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Zobayer Rabbi

Sep 4, 2008 at 2:49 PM
You could be right, but something is really messed up in your installation.  Somehow you're going to need to get a clean working install of MOSS.  It's not obvious to me what is wrong here.

Sep 8, 2008 at 10:56 AM
Edited Sep 8, 2008 at 11:10 AM
Hi, while i try to configure FBA in i face a problem that it cannot access the Globalresource. Can any one help me about it? $0$0$0$0Regards, $0$0Zobayer Rabbi$0
Oct 6, 2008 at 8:01 AM
Hello Mike,$0I create a VPC with windows server 2003. and install MOSS. now i will apply FBA on that. Can you please give me a guideline about this?$0$0$0$0$0Regards,$0$0Zobayer Rabbi$0
Oct 6, 2008 at 1:10 PM

on a fresh MOSS install you should be able the install FBA and this FBA solution the way described on this page. NOTE: the has been a new release of the solution a few day ago - so download the new WSP from this website.

Oct 20, 2008 at 5:34 PM
I hate to tell you man but this is a simple fix and someone already pointed to your problem:
You MUST have at least one user in the aspnet database before CKS FBA will work. You will continue to receive this error until you create a user. Luckily, you can create a user with the CKS form. Go to:
Site Actions > Site Settings > Modify All Site Settings > FBA Role Management > New User
If you don't see "FBA Role Management" go here: http://sharepointaddress/_layouts/FBA/Management/UserNew.aspx

Fill out the form, create the user, and then you should be good.
Oct 21, 2008 at 5:06 AM
Paul,$0Thank you for your reply. But i created FBA user from website. so i should not get this error. $0$0Whatever i install CKS FBA in a new server. and its working nicely. i think i had some mess in the previous server. $0$0Thanks again$0$0$0$0$0Zobayer$0
Oct 12, 2010 at 6:22 PM

I have Roles disabled and never deployed it in the first 1.0 release of FBA. I've updated to a newer version and get this error when click on a user account in fba management, I currently can't change password, reset or delete accounts because of this error.


How do I disable the roles request so this error goes away.

Oct 12, 2010 at 7:32 PM

Here is what my web.config says about roles, I never created any role information or setup in my database when I first setup my users. I just need the roles feature to stop creating errors for normal users.



    <!-- membership provider -->
    <membership defaultProvider="AcAspNetSqlMembershipProvider">
        <add name="AcAspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="AcSqlConnString" enablePasswordRetrieval="true" enablePasswordReset="true" requiresQuestionAndAnswer="false" applicationName="/" requiresUniqueEmail="false" passwordFormat="Encrypted" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="4" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" passwordStrengthRegularExpression="" />
    <!-- role provider -->
      <trustLevel name="WSS_Medium" policyFile="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\config\wss_mediumtrust.config" />
      <trustLevel name="WSS_Minimal" policyFile="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\config\wss_minimaltrust.config" />
      <trustLevel name="WSS_Custom" policyFile="C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\config\wss_custom_wss_minimaltrust_9adb0513-cb25-46ad-b2c1-55c8d45cda8f.config" />
      <remove verb="GET,HEAD,POST" path="*" />
      <add verb="GET,HEAD,POST" path="*" type="Microsoft.SharePoint.ApplicationRuntime.SPHttpHandler, Microsoft.SharePoint, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />
      <add verb="OPTIONS,PROPFIND,PUT,LOCK,UNLOCK,MOVE,COPY,GETLIB,PROPPATCH,MKCOL,DELETE,(GETSOURCE),(HEADSOURCE),(POSTSOURCE)" path="*" type="Microsoft.SharePoint.ApplicationRuntime.SPHttpHandler, Microsoft.SharePoint, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />

Oct 12, 2010 at 7:54 PM



If you approve a member request from the Intranet site and not the www side or fba side the member/user sites and nothing happends they are not approved or removed from the list. If you go back and do this once more from the fba/www site it works.