How to deploy cks kit

Topics: Internet/Extranet Edition
Aug 27, 2008 at 11:18 PM
Sorry to sound stupid, i just downloaded the CKS kit and i am trying create external collaboration site for sharepoint.  How do i deploy the kit for ECTS?  I am new to this process.  Thanks for the help.
Aug 27, 2008 at 11:21 PM
Can someone provide me step by step to do this?  Thank you
Developer
Aug 28, 2008 at 3:17 AM
The ECTS releases page has an extremely detailed deployment guide:

http://www.codeplex.com/CKS/Release/ProjectReleases.aspx?ReleaseId=15529



Regards,
Mike Sharp
Aug 28, 2008 at 5:57 PM
Edited Aug 28, 2008 at 5:58 PM
Thank you Mike, i will give that a try today.  Also after downloading the newest source code, there is the ECTS folder and other sub folders within the ECTS folder.  What do i do with that?  Im still learning this, so i apologize if I am asking so many questions.  Thanks
Developer
Aug 28, 2008 at 6:17 PM
I think the MSI installer for ECTS should be pretty stable.  Why not just use that, rather than compile from source?  It would be a lot easier, I think, and there haven't been any changes since then.

If you must use the source, work from the PackageSolution folder.  The others will be needed but the build scripts will get what they need, as long as you have everything there.

Mike
Aug 28, 2008 at 6:51 PM
Thanks Mike , much appreciated.
Aug 28, 2008 at 9:01 PM
I successfully installed ECTS to my sharepoint environment.  When adding an external user to a website, when checking to see if they are registered.  I get a message saying "Unable to establish a secure connection with the server"  Any ideas?
Developer
Aug 28, 2008 at 9:22 PM

I'm not real familiar with the ECTS, but I do remember it mentions in the deployment guide that you need a secure connection from the SharePoint server to the ADAM server (which can be on the same machine).  There are instructions in the guide on how to set this up by first setting up a local certificate authority.  I suspect this is what's causing the error.

Regards

Mike Sharp

Sep 8, 2008 at 10:40 PM
I am pass the installation part of ECTS and ADAM.  But I have a question.  Everytime I add an external user  and then I register them.  The password that is issued out is so complicated.  Is there a way to change the way passwords are issued?  If so where can I do that?  Thanks Mike.
Developer
Sep 9, 2008 at 3:21 PM
Search for Membership.GeneratePassword and you'll find it in a number of places, used like this:

            //
            // Generate a password to use for the new account.
            //
            Password = Membership.GeneratePassword(9, 2);

This generates a 9 digit password with two non-alphanumeric characters.  You can change this, but you'll have to re-compile.  I think it might have been nice if this was configurable, but unfortunately that's not the case. 

There is also a ResetUserPassword method used, but it simply calls a method of the cUserManager class that in turn calls Membership.GeneratePassword(9, 2).

Regards,
Mike Sharp
Sep 18, 2008 at 8:44 PM
In regards to the "Unable to establish a secure connection with the server" error I struglled with this for a while and finally got this to work.

If you look in the System Event log of the server that you have ADAM installed and see if you have an error with the source "Schannel" and event ID of 36870 with a description of "A fatal error occurred when attempting to access the SSL server credential private key. The error code returned from the cryptographic module is 0x80090016."  There are a couple of things that could be getting in your way. 

First of all try going into the certificate manager and choose the Server Account certificate store and export the certificate you are using for ADAM including the private key and choose to delete the private key on export.  Once it is exported reimport it.  Also add the Service Account Certificate store for the ADAM instance to the certificate manager and copy the certificate from the Server Account certificate store into the ADAM Service Account certificate store.  Restart ADAM and see if you are still getting the error.

If you are still getting the error the account that ADAM is running under may not have read access to the certificats private key.  If you run the command "certutil -v -store my" you will see a verbose list of info about the certificates on the server.  Locate the info about the certificate you are using in ADAM.  Just before the info about the private key wou will so a long number with a format like this:
19c5cf9c7b5dc9de3e548adb70398402_109a4756-23a9-4472-8dab-c302f6b54f26
Look in the directory "C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys" for a file withthe same name as that long number.  Grant read access to the file for the account you are running ADAM under.

If you are still getting the error and you are running ADAM and MOSS on the same server and you are running on Windows Server 2003 with SP1 you could be running into the issue described in this Microsoft KB Article: http://support.microsoft.com/default.aspx?scid=kb;en-us;896861

I know this is long winded but hopefully it will help.
Sep 22, 2008 at 3:23 PM
Thanks for the tips and information all.....It doesnt give me that error message anymore...thanks alot.....
Sep 22, 2008 at 4:22 PM
Hawkmage......

I have the environment setup for internal and external collaboration....With this kit i notice that uploading documents will only allow me to do one document at a time...I know externally that is how it should be i think, but internally we should be able to upload multiple documents.  Is there a way to turn that on?  Also, if im in the shared documents and i try to open it in explorer view, it doesnt allow me too.. Any ideas?  Thank you