This project is read-only.

permissioning signout.aspx

Topics: Internet/Extranet Edition
Aug 29, 2008 at 7:08 PM
My FBA implementation is working great except for the sign out link once the user's already logged in. The  _layouts/signout.aspx page throws a 403 access denied error. Any tips/red flags on pemissioning that page, ie: can I just set it to anonymous access?
Aug 29, 2008 at 7:22 PM
I don't see a signout.aspx page in the project, I assume it's one you added?  I would add the page to a document libary, rather than the _layouts folder.  That way you can manage it's permissions easier.  I assume the rest of the site is anonymous?

Mike Sharp
Aug 29, 2008 at 7:59 PM
Sorry my bad. I'm using a custom logon page solution that replaces the generic login.aspx in the _layouts folder; the signout.aspx resides there as well. I wasn't really getting the results I wanted with the login web parts on  an anonymous web part page, so I opted for this instead. Guess  i'm kinda "breaking the warranty" by using taking a hybrid approach, so i'll quit bugging you guys and pose this inquiry elsewhere. Thanks!
Aug 29, 2008 at 8:51 PM
What, I get a warranty?  :^)

Actually, I think there's a fine-grained permission,  I forget exactly what it's called, but it's somethink like LayoutsPageAccess.  You might need to grant that to the account your anonymous users are coming in on.  But there are other pages that are accessible when anonymous users are allowed on the site, like searchresults.aspx, so it may be something trickier.

You might be able to do this with something like:

    <location path="_layouts/yourCustomPages/signout.aspx">
                <allow users="*" />

but I feel there's probably a SharePoint way to do it instead.

Mike Sharp
Aug 29, 2008 at 9:20 PM
Thanks for the tips Mike! I give those a shot.
Aug 29, 2008 at 9:43 PM
Edited Aug 29, 2008 at 9:45 PM
Oh hey, look at this:

I forgot about the lockdown feature.  It's active by default, and if you deactivate it, Lockdown mode will be turned off.  Specifically, when deactivated it turns on the View Application Pages permission.

Aug 29, 2008 at 10:46 PM
Good resource, that! I may yet figure this out. :) Thanks again