This project is read-only.

CKS:EBE Comments Not Showing, Can't Submit Comments

Topics: Enhanced Blog Edition
Mar 20, 2009 at 7:16 PM
Hey folks.  Just built the newest version of the EBE code (cks-26083) and installed.

I was hoping this problem was fixed, but is not (see previous post  When I'm authenticated as anyone aside from the owner of the blog, I cannot see the comments.  Doesn't matter what theme I'm using, it says 0 comments.  Anyone else seeing this?  Any fixes?

Additionally an non-owner authenticated user can no longer submit Comments.  When I click Submit it sends them to a page telling them they do not have permissions for the page (standard sharepoint error page, not themed) with a link to sign-in as a differnet user.  Any thoughts?

Mar 22, 2009 at 9:33 AM
I fixed this issue with the next checkin (this will be the Change Set > 26122).

Mar 23, 2009 at 3:46 PM
Thanks, that's great.  Clearly I must be doing something wrong though.  I downloaded latest source posted yesterday, rebuilt solution, upgraded, deployed, activated, etc.

Same problems exist, but now with new problems.  I tried to create a new post as owner.  Worked ok.  Then changed sign-in to non-owner, and tried to view post, get the error "Failed to render control: The post ID is invalid".  Removed the BlogTitleForUrl field, then didn't get error, but clicking title in list didn't go anywhere.  Created another post, and it worked fine.  Went back to previous post, put a BlogTitleForUrl in, and it worked fine.  Then logged in as non-owner again and it gave the the Failed to render again.  argh.

Also the Posts seem to have a Category field (single selection) and Categories (multiple selection) now.  Didn't recall that before, but doesn't mean it wasn't there.  The Tags control on the Post display doesn't seem to pick up either list, but if I filter I get the post showing under the Categories selection (but not Category). 

By the way, all of this seems to happen regardless of Theme.

Could I have screwed something up with the build and install?  Should I do a compelete uninstall and reinstall maybe?

Mar 23, 2009 at 7:32 PM
Followup - uninstall / reinstall didn't change anything. :(
Mar 24, 2009 at 10:48 PM
could you please check that the post which one of your users can not access is published (not in moderation status = pending) and the published date is in the future?

Mar 25, 2009 at 6:12 PM
Edited Mar 25, 2009 at 6:54 PM
That's right. They (posts and comments) are all approved. Dates are not in the future.

In fact non-owner user sees the post fine in the post list (home), just has problem when they click to view the post itself.

Seems like maybe things are not installing correctly. For example, if I'm reading the code right (what I've looked at and makes sense to me) Category field should be hidden from new, update and views, but it is not.


Mar 28, 2009 at 7:22 PM
I hope the bug is now fixed. Could you please try again with the latest checkin?

Mar 30, 2009 at 3:50 PM
Hi Rene, sorry to say but nothing seems to have changed.

Downloaded newest source.  Did clean solution (just in case).  Built solution.  Try upgrade first.  Then did full uninstall, reinstall.

Still get PostID error when not owner.  Non-owner still cannot post comments, nor see comments posted by owner.

Anyway to confirm that what I built and installed is actually the latest source?  I can see that the changelog.txt file has been updated in the directories I am building from, but don't know what files you changed.

Apr 2, 2009 at 12:52 AM

Can you check the settings on your comments list. Specifically the versioning, checkin/checkout etc.

If you change it so there is no versioning and so that basically everyone can see the comments do you still have the problem?

Apr 2, 2009 at 3:56 PM
Thanks Vince, you've saved the day.  I'm a freakin' idiot I guess, should have dug around in those settings.

Versioning was off.  Approval was on, but as noted in another post it didn't seem to matter, all comments are approved without doing anything.  What I did find was that my group for blog visitors was not propagated to the Comments list.  Other lists had the group and it's permissions, but not Comments.  So added that group with Contribute permissions (they have Read on everything else now), and that did the trick.

Still have issue with Category v Categories, and BlogTitleForUrl in the Posts.  I should probably create separate threads for those.

Thanks Vince, appreciate the help.

Apr 2, 2009 at 4:07 PM

The PostTitleForUrl shouldn't really be touched (actually shoudn't be visible), it is purely there to support the URL re-writing. However if you modify it it should still work. I guessing your problem is another permissions thing, where you can see the post, but other can't??

The Category field should also be hidden. It is the default one WSS creates and is hidden by the EBE when you activate the feature. The Categories field is used by the EBE and allows you to assign multiple categories to a blog post. It uses a multi-value lookup field, which has problems with CAML (you don't get the selected values back in a query, but you can filter on them). The EBE solves this by having another field (CategoriesAsText I believe) which is updated by a EventHandler on the Posts list.

The categoris on your blog come from the categories list. Posts are filtered via the Cargories column and the Tags bit displayed for each post uses the CategoriesAsText field.

HTH, Vince
Apr 2, 2009 at 4:15 PM
Vince - this is what concerns me, and why I think I've got something screwed up.

When I initially installed 2.0, I think BlogTitleForUrl and Category were in fact hidden.  But since I've been working with Rene to fix above, and building/installing the latest sources, they've appeared.

If I do not enter something in BlogTitleForUrl, it doesn't work.  The Post title link just goes back to the list, doesn't go to the post itself (same with Read More link).  If I enter some text in that field, it works fine (for me and others).

And I can choose from Categories, and the filtering works (click a Category and it shows related posts), and they show up on the left navigation properly.  BUT, when I go to a Post and under the title it displays the Tags: line, that doesn't work.  Seems like CategoriesAsText doesn't work, isn't there, or something.

Seems like things are not happening properly when I activate the feature.  I've tried deactivating, undeploying, deleting and then starting over, but that doesn't change anything.

Any suggestions you might have would be wonderful. :)

Apr 2, 2009 at 4:38 PM
If you de-activate and then re-activate the feature it *should* run through everything making sure that all lists, fields, event handlers etc are all present & correct. If you activate the feature with DebugView running you will see any errors that occur.

However, my suspicion is that as you have built the DLL it's in your BIN folder?? For the events to be registered and triggered the CKS.EBE.dll will need to be in the GAC.

HTH, Vince
Apr 2, 2009 at 4:46 PM
I'm assuming you mean in the folder structure with the source files, etc.

CKS.EBE.wsp is in the "root" with the batch files for install, upgrade, etc.
CKS.BlogSolution.dll is in bin/Release and obj/Release
CKS.EBE.dll is in DLLs/GAC

Is that right?  Is that what you mean?

I'm going to deactivate and activate again, just to be sure.

Apr 2, 2009 at 4:50 PM
Generally when you are developing you change the web.config to Full trust and place the CKS.EBE.dll in the 'bin' folder of the IIS site. This makes it much quicker and easier.

I was just guessing that you have a version of the CKS.EBE.dll in your bin and so your event handlers cannot be registered?

Apr 2, 2009 at 4:58 PM
That would assume i know what i'm doing.  i do not.  :)

I'm new to developing for sharepoint, really this is the first solution i've built or tried to tweak.  So, i have not changed web.config, nor manually placed any dll's in any directories.  I don't see CKS.EBE.dll in the BIN directory of the iis site either.

Apr 2, 2009 at 5:03 PM
Ok, now i've really hosed it.  I Deactivated from the site, and then deactivated from the web app.  The reversed course, activated for the web app, and then activated for the blog site, and now it isn't working at all.  I just see the regular SP blog site.  btw, i did this via Site Settings and Central Admin.

shoot me now.  pls.
Apr 2, 2009 at 5:12 PM
That's OK, just de-activate & re-activate the WebApp..the web.config entries are missing.

run STSADM -o execadmsvcjobs to ensure the web config modification jobs run in time.

Or you can just wait...this happens sometimes :-( it's a SharePoint 'feature'.

Apr 2, 2009 at 5:39 PM
Gotta love the features.

Ok, back up, and things are looking better.  Not sure why it's changed since i've deactivated and activated before, but previously I also uninstalled and reinstalled in between.

Category field no longer shows, and the Categories / Tags are working now on Tags line - so assume CategoriesAsText is working.

Still see the BlogTitleForUrl field, but it is getting populated by the solution and I don't have to do it.  If I edit a post I see what was inserted in that column, so that's good.