EBE Anonymous Site -- Authenticating?

Topics: Enhanced Blog Edition
May 28, 2009 at 6:10 PM

My site is a remote server to me, and has anonymous access enabled.  Typically I would click the Sign In link and would get an Integrated Auth prompt, enter my creds, and log in.  Now, using the 27717 changeset, I click the link and am taken to the page "CKS Blog preventing access to system pages" with a Login link.  The Login link just brings me back to the same page.  How can I authenticate remotely while the site has anonymous enabled?  I would like to keep the "Enable the securing of system pages " option enabled if at all possible.

May 28, 2009 at 9:53 PM


I noticed that on another blog. Can't reproduce it yet. But I'll look into this issue.


Jun 4, 2009 at 8:27 PM


I still can not reproduce the problem. Could you tell me something about your environment? What is the Url to your blog? http://.../a/b/...

What theme do you use?


Jun 4, 2009 at 10:50 PM


And uh, that blue theme :)  You'll also see you cannot see comments (auto approved if spam-free).  Specifically the 3 comments here:


Jun 20, 2009 at 5:34 AM

The comments are now appearing with the latest changeset, 27915.  Authentication is still an issue, however.

Apr 20, 2010 at 4:13 AM

Using the latest source code as of writing (changeset 40714), I noticed an option under the CKS.EBE Settings (blog settings) "Secure System Pages", which is turned on by default.

Turn it off an anonymous users will be able to access SharePoint libraries (e.g. Photos/Archive), using the normal SharePoint UI however - but better than nothing IMHO.