EBE not showing up on extended internet site

Topics: Enhanced Blog Edition
Jun 17, 2009 at 3:39 PM

We recently deployed a reverse proxied MOSS solution and wanted to setup a CKS:EBE enabled blog site.  We've created the new site and applied the CKS:EBE.  It is/was working beautifully internally.  When we extended the site to an internet zone for external users to access, the site shows up with the standard SharePoint blog interface.

I tried deactivating and reactivation the community kit with the same resutls.  I've compared the web.config's of the internal and external zone sites, and they both look ok.  I've even moved the ebe handler, module, and expression builder to the top of their respective sections in the web.config of the external site with no luck.  I can tell its there because I can manually access the home.aspx page instead of the default.aspx with the theme enabled (but none of its links work - they all give 404s).

I've seen a lot of posts similar to this one where it doesnt seem the community kit blog edition extends well to other zones, but I've never seen a fix for it.  Is there something I'm missing?  Are there any manual entries that need to be made to the external sites config?

Desperate for help on this...


Jun 18, 2009 at 11:53 AM

Try adding your internet URL in one of the five Zones in AAM

Jun 18, 2009 at 12:42 PM

When I extended the site, it put the internet url in the 'internet' zone AAM for the internal site.  The site resolves ok and is fully functional using native SharePoint technology.  Its only the CKS:EBE that doesnt show up on the outside site.  Using the external site, I can even go into the site settings and see that its installed and activated...the look and feel just doesnt change. 

Any input?

Jun 19, 2009 at 8:17 AM

I just want to make sure that external (internet) URL is there in AAM. I faced similar issue and simply adding the www URL in AAM helped me resolving the similar issue.

Or try reinstalling again after removing and IIS Reset/Machine Restart with lockup if this is web farm

Jun 22, 2009 at 4:48 PM

Unfortunately that didnt help.  I made sure that the site had both url's added to the AAM (the external and the one the reverse proxy is using). Still no luck.  It's wierd though because the site IS externally accessable.  I can view and browse entries. It's just that it not showing any of the themes or layout changes of the community kit. It has the standard look and feel only.

Jun 25, 2009 at 7:17 PM

So heres the fix....


Apparently the cks:ebe doesn't like reverse proxy devices rewriting urls.  SharePoint seems fine with it.  So - if you have www.myexternaldns.com pointed to your reverse proxy device - and your reverse proxy device is talking to your SharePoint farm on reverseproxydns.myinternalcompanyname.com, you will continue to have the problem referenced above.  Although native SharePoint features will continue to work normally externally, the enhanced blog community kit feature will not. You can bypass the reverse proxy internally by setting up an additional zone SharePoint.myinternalcompanyname.com and you'll see it work fine internally.

The work around - configure your external dns to match an internal dns. That way somednsentry.MyCompanyName.com in your external DNS references your virtual IP on your reverse proxy appliance, and somednsentry.MyCompanyName.com in your internal DNS references your SharePoint farm.  You can then configure your reverse proxy appliance to no longer rewrite your URLs, but simply pass the traffic.  If you wanted other vanity URL's externally, you can configure them as aliases to the appliance and have the appliance re-write them to the acceptable entry.  Perhaps in future enhancemnts to the CKS:EBE you will be able to extend it easier...