Tag Cload, Page not found error

Topics: General/Misc.
Jan 2, 2008 at 2:59 AM
Hi All,

I have just tried to use the TagCloud solution and it all works great, I get the tags listed etc.

When I click on a tag in the tag cloud web part it gives me a 404 page not found error for the url below:


any ideas as to what is going on here?

This has been installed on MOSS2007 with sp1

Jul 28, 2008 at 9:16 AM

Did you fixed this?
I have the same problem on my MOSS environment.

Jul 28, 2008 at 10:52 AM

The solution!


  • Create a new page for tags browser - links in the Tag Cloud web part is redirected to the tag browser web par
  1. Go back to Home
  2. Click on Site Actions
  3. Click on Create and select "Web Part Page"
  4. Please enter “tags” into the Title and URL name field
  5. Select "Header, right column, body" layout
  6. Go with the default value "Shared Documents" for the document library
  7. Click OK
  8. A page at http://PORTALURL/Shared Documents/Tags.aspx will be created
  9. You will see the page in edit mode, please follow the instruction below to deploy the tag browser web parts


  • Deploying the Tag Browser web part to the new page - the Tag Browser web part shows the titles and URLs of items with tags
  1. Download the Tag Browser web part (SPTagBrowser.dwp)
  2. Go to the new page for tags browser you created in the previous steps.
  3. Import the web part into the page
    1. Click Add a Web Part in one of the zones, e.g. body
    2. In the Add Web Parts dialog box, click Advanced Web Part gallery and options in the lower right corner.
    3. In the Add Web Parts pane, click Import.
    4. Browse to the location of the TagBrowser.dwp file, and then click the Upload button. After uploading, the page will refresh, and "Tag Browser" should be displayed under Imported Web Part.
    5. Drag the icon next to "Tag Browser" to a zone on the page
    6. Click "x" to close the "Add Web Parts" dialog box.
    7. You should see "No tags specified in the query". It's expected
  4. Click "Exit Edit Mode" to confirm the change.
  5. Please copy the part of the current URL after the PORTALNAME up to the question ? mark.
  6. e.g. http://wsssearch.com/Shared%20Documents/tags.aspx?PageView=Shared.
  7. Go back to the home page
  8. Click on down arrow of the Tag Cloud web parts
  9. Click on "Modify Shared Web Part"
  10. Expand the Tagging Setting section
  11. Make sure if the text displayed in the TagPageURL field is correct, e.g. "/Shared%20Documents/tags.aspx" or the landing URL of your tags page. If not, please paste the URL to the TagPageURL field.
  12. Click OK. The links on the tag cloud will forward to the page
  13. To test it, please go back to the home page.
  14. Click on the tag in the tag cloud web part
  15. It should redirect to the new page you just created and add the "?tags=TAG_NAME" to the url. The tag browser should show the title and url of list item with the tag TAG_NAME.
  16. You are done with web parts deploying. You can add the Tags column to any lists you want. The tag cloud web part automatically put data from every Tags column.
Jan 21, 2009 at 10:09 AM
Thank you very much, it really helped me!