This project is read-only.

CKS FBA installation 'FBAManagementSelf'

Topics: General/Misc., Internet/Extranet Edition
Oct 15, 2008 at 2:01 PM
Edited Oct 15, 2008 at 2:03 PM
Thanks for a great product it realy takes FBA a huge step forward.
When installing CKS FBA i get the following error:

stsadm -o activatefeature -name FBAManagementSelf -url <MY URL>
Dependency feature with id 01aa8d8b-000a-4c35-8f4f-5d1280377650 for feature 'FBAManagementSelf' (id: 23c44729-fb03-4882-a0bf-c6fb3ddd81fd) is not installed.
stsadm.exe -o activatefeature
           {-filename <relative path to Feature.xml> |
            -name <feature folder> |
            -id <feature Id>}
           [-url <url>]

What is this feature?

Oct 16, 2008 at 7:23 AM
Edited Oct 16, 2008 at 7:24 AM
I'm also getting this error - I voted on the issue here:
Oct 16, 2008 at 2:24 PM
I was able to get around this issue by commenting out this feature (which turns out to be the "My Settings Save Override") in the feature.xml located here:

C:\Program Files\Common Files\microsoft shared\Web Server Extensions\12\TEMPLATE\FEATURES\FBAManagementSelf\feature.xml

Then I was able to activate the FBAManagementSelf Feature in the Site Collection. I'm not sure what this My Settings feature does and whether it impacts anything else. I'm not able to get Membership Request or Password Recovery working and the Role Administration throws an "Unknown Error". The Membership Request throws an error about the Password being invalid and the Password Recovery webpart tells me that it was unable to retrieve my password. If anyone has resolutions to these issues or perhaps indicate what I may be doing wrong, I would be most grateful.
Oct 16, 2008 at 2:41 PM

The feature activation was my fault. As spminion pointed out, I took out the code but never knew there was a dependancy to remove. (I know its out standing to do, but like everyone else I'm being dragged back to paying customer work again).

As for the password recovery errors a common mistake in the Provider config, is to enable question and answer and or choose not to hash the password, I think. To my knowledge nobody used the role admin? Mike did you??

I wish I had a test environment set up because I'm sure I could fix those fairly quickly.


Oct 16, 2008 at 2:50 PM
Thanks Anthony for such a quick response.

If I change the password format from Encrypted to Hash, I find the passwordStrengthRegularExpression doesn't work. Does that sound right to you?

Thanks again for your response and hard work on this!
Oct 16, 2008 at 3:01 PM

*insert blushing face* passwordStrengthRegularExpression is not yet implemented, don't use it :)

Oct 16, 2008 at 5:01 PM
Thanks for clearing out this point, and to explain the current status.
Oct 17, 2008 at 2:58 PM
Hi Anthony,

Role administration partly least in my production code, which is based on changeset 17054.  That is, I can add a role to a sharepoint group, but I can't add new roles via the role admin.  Haven't tried to debug it, though.  The RoleNew page throws a null reference exception...   Any users that were added to a role using the visual studio management tool work in SharePoint just like an AD Security group does. 

Mike Sharp
Oct 17, 2008 at 3:55 PM
I concur with Mike. Adding Roles to SharePoint works, but not adding new roles.....which is fine. We don't really need it right now.

As for the Password Recovery, I've changed the Password Format to Hashed and EnableQuestionandAnswer to False. Unfortunately, I get this error:

"There was an error sending the email, please check with your administrator"

Any ideas? Thx!
Oct 17, 2008 at 4:21 PM
This could be one of several problems.  If the call to SendMail fails for any reason, such as a problem with the XSLT, or the SMTP server can't be found, you'll get this error.

Try temporarily replacing the XSLT with a simple text-only one ( remove the internal functions like <xsl:value-of select="MembershipRequest:get_Password()" /> ) and then re-try.  If this works, then for some reason the request is missing certain essential elements that the XSLT is expecting.  It may very well be the change password page is misconfigured, because there are several references to the ChangePassword URL in the XSLT like:  MembershipRequest:get_ChangePasswordURL()

If changing to a text-only XSLT doesn't fix it, then it's probably failing to connect to the mail server for some reason.

Mike Sharp
Oct 17, 2008 at 7:45 PM
Thanks Mike, I'll give that a try.
Apr 8, 2009 at 11:32 PM
The XSLT emails are failing for me as well, but due to permission issues when trying to load the XSLT file.  Perhaps this needs to be done with elevated privileges.

As for Role Admin - see for how to fix.
Jan 7, 2010 at 7:35 PM

I am having the same issue with the password recovery option.  I am getting the error:

There was an error sending the email, please check with your administrator

I changed the XSLT file to be very basic (see below) and it still does not work.  Is there someplace that I am supposed to edit in order to add the name of the SMTP server?

<?xml version="1.0" encoding="UTF-8" ?>
<xsl:stylesheet version="1.0" xmlns:xsl="" xmlns:MembershipRequest="cks:MembershipRequest">
  <xsl:template match="/">
        <title>Membership Password Recovery</title>
            <p>You have requested this mail because you have forgotten your password.</p>

            <p>Thank you.</p>



Jan 8, 2010 at 1:31 PM
I'm having the same problem, even with a very simple template like yours... Any luck yet? Cheers
Jan 8, 2010 at 1:31 PM
Edited Jan 8, 2010 at 1:32 PM
Sorry about this.... (= I'm having the same problem, even with a very simple template like yours... Any luck yet? Cheers
May 7, 2010 at 12:42 PM

I know this is an old post but for people still looking for a fix to this issue, 

I fixed it by copying the PasswordRecovery.xslt file into a document library (which has anonymous access) and configuring the FBA (_layouts/FBA/Management/FBASiteConfiguration.aspx) to point to that file. 

This sent the mail no problem.


Hope this helps.


May 7, 2010 at 2:13 PM

Thanks for remembering, we had a workaround that didn't envolve xslt template files, but I'll give this a try next time.

B Well

Aug 3, 2010 at 10:44 AM


  Enter the setting

          <smtp from="">
              <network host="servername" port="25" />

in web .config of web application under <>

This will solve the problem of send mail process in password recovery.





Oct 12, 2010 at 6:48 PM

Machincity is correct, this is a critical step most miss. After changing my email server to a Hyper-v setup I lost access to external email outgoing and it took some while to find this setting.


Also in Exchange 2007 and I bet 2010 Relay anonymous for alerts and outgoing email - there is no GUI way to truly enable relaying in Exchange. you must use a command to enable the receiving connector to allow true anonymous relay from your sharepoint IP address.