CKS:EBE Building - SelectedBlogTheme Problem

Topics: Enhanced Blog Edition
Mar 17, 2009 at 9:28 PM
Hello all.  Great solution.  I've been playing with 2.0 release and realized I really should have newer files due to some problems I was experiencing.

Since I don't see a newer release or wsp file, downloaded the latest source (cks-26083) and am trying to build.  Warning - I'm new to this.  I'm getting the following error:  'CKS.EBE.BlogContext.SelectBlogTheme.get' must declare a body because it is not marked abstract or extern.

Not finding much that points me in the right direction.  Any suggestions?  Or does anyone have a recent wsp built that is available?

Thanks very much.
Mar 17, 2009 at 9:31 PM
PS: Switched from Debug to Release and also getting errors on this statement.

string

[] arBits = sProvider.Split(new[] { ',' }, 2);

Seems like I'm missing something.

 

Developer
Mar 18, 2009 at 12:04 PM
Hi,
please install the .NET framework 3.5 on the client where you compile the sourcecode.

René
Mar 18, 2009 at 3:01 PM
Thanks, I'll try that.  I assume it won't have any ill effects on the sharepoint install?

Brett
Developer
Mar 18, 2009 at 6:57 PM
It won't. But you do not need it on your SharePoint servers. Just the machine where you want to compile the sourcecode!

René
Mar 18, 2009 at 7:23 PM
Sadly we're just starting out with customizing Sharepoint and don't even have a separate dev environment yet (yeah, dumb).  So I don't have a separate location setup for building this.

Installed .Net 3.5, etc.  Still not building, same error.  Tried adding system.core.dll to References, that didn't help.  Any further suggestions?

Brett

PS: sorry for bugging you folks with dumb*%% questions.
Mar 18, 2009 at 7:44 PM
PS again: Using VS 2005 and the sln for that.  Would that matter?  Should I use VS 2008?
Mar 20, 2009 at 7:25 PM
Just replying to myself.  Yup, 2008.