RSS Feed Links - There Still May Be An Issue

Topics: Enhanced Blog Edition
Jun 2, 2009 at 5:43 PM

I see there was an update from Rene in regard to the relative post links within the RSS feeds (ala */rss.xml). I believe there is still an issue even with the latest code. The situation is when there is a blog site under a seperate site collection within a managed path.

So if I have a blog site at: http://main/sites/TeamSites/TeamBlog, a relative post link may be "/sites/TeamSites/TeamBlog/archive/2009/04/24/consolidating-calendars-in-sharepoint.aspx".

When the RSS feed is generated it receives the links from the CKS.EBE.RssHandler as the combined site collection URL and the relative post link, similiar to: http://main/sites/TeamSites/sites/TeamSites/TeamBlog/archive/2009/04/24/consolidating-calendars-in-sharepoint.aspx. The "sites/TeamSites" is repeated and thus is not the correct link.

I currently have a workaround by modifying the OOTB RssXslt.aspx but that is a system file.

Can anyone deny or confirm this issue? Will there ever be a new release other than code?






Jun 4, 2009 at 8:25 PM

Hi Steve,

what build did you use? Did you compile you own wsp, or did you use an existing from this page?

The problem seems to be gone with the latest version.


Jun 4, 2009 at 8:29 PM

I grabbed the latest WSP from the site. When you say latest version, do you mean code or WSP?


Jun 5, 2009 at 6:15 PM


Jun 5, 2009 at 7:57 PM

Ok. thanks. Looks like the Helper.cs is missing from the LinkBacks folder. I tried to use the same one as the root but they must be different helpers…

From: ReneHezser []
Sent: June 05, 2009 02:15
To: Steve Mann
Subject: Re: RSS Feed Links - There Still May Be An Issue [CKS:58247]

From: ReneHezser


Read the full discussion online.

To add a post to this discussion, reply to this email (

To start a new discussion for this project, email

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at

Jun 8, 2009 at 12:28 PM

Version 27717 was the latest set without the LinkBacks\Helper.cs reference. I compiled a new CKS.EBE.dll and it resolved the links. It busted our template as the template was created using an older version. We'll create a new template and see what happens. Thanks!