Q&A about initial setup for CKS:UGE 1.0

Coordinator
Feb 26, 2007 at 1:32 AM
As soon as you create your user group website with the CKS:UGE, you should go to the site URL/Lists/Getting%20Started%20with%20the%20CKS/AllItems.aspx page and follow the checklist to configure your site. If you have any questions about any of the tasks, don't hesitate to ask here.

<Lawrence />
Mar 12, 2007 at 1:52 PM
I've just created a test version of this site template. Now I'm confused as to the login bit for anonymous users.
I've made the site accessible for Anonymous Users. WHen I click on the link "Join group" as the administrator, I get the Sign-up-page. If I click it as a user without permissions on the site, I get the standard logon error:

Error: Access Denied
Current User
You are currently signed in as: (my username)

Sign in as a different user
Request access

Also, will a user get an "account" at the community site? Or is the registration only to register for news letters and such?

Any suggestions about how to set up the permissions correctly?
Coordinator
Mar 21, 2007 at 12:55 AM
You'll need to configure the "Sign-up" survey web part (which is what the "Join group" link displays) separately and after you've enabled anon access at the site level. The config is identical to what I had blogged about here.

Alas, there's no user account creation feature in CKS:UGE 1.0, but we're definitely considering adding such a feature in 2.0.


Kaisa wrote:
I've just created a test version of this site template. Now I'm confused as to the login bit for anonymous users.
I've made the site accessible for Anonymous Users. WHen I click on the link "Join group" as the administrator, I get the Sign-up-page. If I click it as a user without permissions on the site, I get the standard logon error:

Error: Access Denied
Current User
You are currently signed in as: (my username)

Sign in as a different user
Request access

Also, will a user get an "account" at the community site? Or is the registration only to register for news letters and such?

Any suggestions about how to set up the permissions correctly?

May 15, 2008 at 2:31 AM
Hi Lawrence,

I've followed your instructions to setup anonymous access to the Survey; it works fine when the survey just has a few questions that fit in a single page (the NewForm.aspx). However, I've added several questions with redirections based on the previous answers and therefore, when I hit the Next button (which directs the user to an EditForms.aspx page), I'm being asked for credentials. Is there's a way to ensure that all the questions of my survey can be answered in an anonymous way?

In a previous answers, you mention "... You'll need to configure the "Sign-up" survey web part"; what do you mean by this? I've done the configuration of at the survey level itself but nothing at the web part level. Am I'm missing a step?

Thanks in advance and best regards